Version 1.5.66

  • Re-add the Retry-After header when the API returns a 429 error. This header was lost on the last version.
  • /bookedhours/attesthours/: Bug fix - Fix attestation failing with HTTP 400 after hours are approved via PUT.
  • When activating a Next Project API integrator for a customer, an integrator contact with an email must be selected. That email is stored on the API user so a OneLogin invite can be sent.
  • /workorderrow/{workorderrow_id}: Add new DELETE endpoint to remove a work order row.
  • /journal/note/{journalnoteid}/document/: A new GET-endpoint that lists documents for a specific journal note.
  • /journal/note/{journalnoteid}/document/: A new POST-endpoint that creates documents for a specific journal note.
  • GET /journal/{id}/document/ and GET /journal/{id}/workforce/ are sorted by id descending.
  • Uploading a document that is too large now returns 413 Request Entity Too Large with a clear message, instead of a generic 500 error. This change affects the following endpoints:
    • POST#/document/
    • POST#/voucher/
    • POST#/supplierinvoice/
    • POST#/customer/document/
    • POST#/supplier/document/
    • POST#/journal/document/
    • POST#/journal/note/{journalnote_id}/document/
      Timeout on certain endpoints has been updated from 60 to 115s. This change affects the above endpoints, as well as the following endpoints:
    • GET#/voucher/{voucher_id}/pdf
    • GET#/supplierinvoice/{supplierinvoice_id}/pdf
    • GET#/document/{document_id}/file
    • GET#/customer/document/{document_id}/file
    • GET#/supplier/document/{document_id}/file
    • GET#/customerinvoice/{customerinvoice_id}/pdf
    • GET#/customerinvoice/{customerinvoice_id}/edi
    • GET#/customerinvoice/{customerinvoice_id}/attachments/{attachment_id}/file
    • GET#/customerinvoice/{customerinvoice_id}/voucherrows/{voucherrow_id}/pdf